NDS EMUL – Drastic 2.4.0.1a crack(Lollipop / marshall compatible)

drastic No error version.
In version 2.5 and later, you will need to do the rooting, but this version can be installed and used without rooting.

There is no difference in performance from the latest version, so there is no problem using it.

Drastic2.4.1a

Facebook Comments